Back to overview
Resolved

POS transactions do not complete

May 26, 2026 at 9:06am UTC
Affected services
Medusa

Resolved
May 26, 2026 at 10:16am UTC

Medusa upgraded and worker fixed. Should now be working

Created
May 26, 2026 at 9:06am UTC

Card payments are approved on the card machine but the order does not fulfill in Medusa. No order is created. Payment is currently being taken manually. Investigating a fix